Browse Source

Attempt to fix bundler dependency errors in Travis.

* Put Gemfile.lock in RCS
* Remove Sisow from Gemfile and let gemspec handle that.
* Let the loader include Sisow gem.
tags/3.0.0
Bèr Kessels 7 years ago
parent
commit
a77bbf2184
3 changed files with 313 additions and 2 deletions
  1. 0
    1
      .gitignore
  2. 0
    1
      Gemfile
  3. 313
    0
      Gemfile.lock

+ 0
- 1
.gitignore View File

@@ -6,7 +6,6 @@
.project
.sass-cache
coverage
Gemfile.lock
tmp
nbproject
pkg

+ 0
- 1
Gemfile View File

@@ -3,6 +3,5 @@ source 'https://rubygems.org'
# Provides basic authentication functionality for testing parts of your engine
gem 'spree_auth_devise', github: 'spree/spree_auth_devise', branch: '2-2-stable'
gem 'therubyracer', platforms: :ruby
gem 'sisow', '~> 1.5'

gemspec

+ 313
- 0
Gemfile.lock View File

@@ -0,0 +1,313 @@
GIT
remote: git://github.com/spree/spree_auth_devise.git
revision: 01901766a2562026e2f3eb523a3f0f9bea8ae31e
branch: 2-2-stable
specs:
spree_auth_devise (2.2.0)
cancan (~> 1.6.10)
devise (~> 3.2.3)
devise-encryptable (= 0.1.2)
json
multi_json
spree_core (~> 2.2.0)

PATH
remote: .
specs:
spree_billing_sisow (0.0.4)
sisow (~> 1.5)
spree_core (~> 2.2.0)
spree_frontend (~> 2.2.0)

GEM
remote: https://rubygems.org/
specs:
actionmailer (4.0.5)
actionpack (= 4.0.5)
mail (~> 2.5.4)
actionpack (4.0.5)
activesupport (= 4.0.5)
builder (~> 3.1.0)
erubis (~> 2.7.0)
rack (~> 1.5.2)
rack-test (~> 0.6.2)
active_utils (2.2.3)
activesupport (>= 2.3.11)
i18n
activemerchant (1.42.9)
active_utils (~> 2.0, >= 2.0.1)
activesupport (>= 2.3.14, < 5.0.0)
builder (>= 2.1.2, < 4.0.0)
i18n (~> 0.5)
json (~> 1.7)
money (< 7.0.0)
nokogiri (~> 1.4)
activemodel (4.0.5)
activesupport (= 4.0.5)
builder (~> 3.1.0)
activerecord (4.0.5)
activemodel (= 4.0.5)
activerecord-deprecated_finders (~> 1.0.2)
activesupport (= 4.0.5)
arel (~> 4.0.0)
activerecord-deprecated_finders (1.0.3)
activesupport (4.0.5)
i18n (~> 0.6, >= 0.6.9)
minitest (~> 4.2)
multi_json (~> 1.3)
thread_safe (~> 0.1)
tzinfo (~> 0.3.37)
acts_as_list (0.3.0)
activerecord (>= 3.0)
addressable (2.3.6)
arel (4.0.2)
awesome_nested_set (3.0.1)
activerecord (>= 4.0.0, < 5)
aws-sdk (1.27.0)
json (~> 1.4)
nokogiri (>= 1.4.4)
uuidtools (~> 2.1)
bcrypt (3.1.9)
builder (3.1.4)
cancan (1.6.10)
canonical-rails (0.0.7)
rails (>= 3.1, < 5.0)
capybara (2.4.4)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
xpath (~> 2.0)
childprocess (0.5.5)
ffi (~> 1.0, >= 1.0.11)
climate_control (0.0.3)
activesupport (>= 3.0)
cocaine (0.5.4)
climate_control (>= 0.0.3, < 1.0)
coffee-rails (4.1.0)
coffee-script (>= 2.2.0)
railties (>= 4.0.0, < 5.0)
coffee-script (2.3.0)
coffee-script-source
execjs
coffee-script-source (1.8.0)
colorize (0.7.3)
crack (0.4.2)
safe_yaml (~> 1.0.0)
database_cleaner (1.3.0)
deface (1.0.1)
colorize (>= 0.5.8)
nokogiri (~> 1.6.0)
polyglot
rails (>= 3.1)
devise (3.2.4)
bcrypt (~> 3.0)
orm_adapter (~> 0.1)
railties (>= 3.2.6, < 5)
thread_safe (~> 0.1)
warden (~> 1.2.3)
devise-encryptable (0.1.2)
devise (>= 2.1.0)
diff-lcs (1.2.5)
docile (1.1.5)
erubis (2.7.0)
execjs (2.2.2)
factory_girl (4.5.0)
activesupport (>= 3.0.0)
ffaker (1.25.0)
ffi (1.9.6)
font-awesome-rails (4.2.0.0)
railties (>= 3.2, < 5.0)
friendly_id (5.0.3)
activerecord (>= 4.0.0)
hashie (3.3.1)
highline (1.6.21)
hike (1.2.3)
httparty (0.13.3)
json (~> 1.8)
multi_xml (>= 0.5.2)
httpi (2.2.7)
rack
i18n (0.6.11)
jquery-rails (3.1.2)
railties (>= 3.0, < 5.0)
thor (>= 0.14, < 2.0)
json (1.8.1)
kaminari (0.15.1)
actionpack (>= 3.0.0)
activesupport (>= 3.0.0)
libv8 (3.16.14.7)
mail (2.5.4)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.25.1)
mini_portile (0.6.0)
minitest (4.7.5)
monetize (1.0.0)
money (~> 6.4.0)
money (6.4.0)
i18n (>= 0.6.4, <= 0.7.0.beta1)
multi_json (1.10.1)
multi_xml (0.5.5)
nokogiri (1.6.3.1)
mini_portile (= 0.6.0)
orm_adapter (0.5.0)
paperclip (3.4.2)
activemodel (>= 3.0.0)
activerecord (>= 3.0.0)
activesupport (>= 3.0.0)
cocaine (~> 0.5.0)
mime-types
paranoia (2.0.2)
activerecord (~> 4.0)
polyamorous (0.6.4)
activerecord (>= 3.0)
polyglot (0.3.5)
rabl (0.9.3)
activesupport (>= 2.3.14)
rack (1.5.2)
rack-test (0.6.2)
rack (>= 1.0)
rails (4.0.5)
actionmailer (= 4.0.5)
actionpack (= 4.0.5)
activerecord (= 4.0.5)
activesupport (= 4.0.5)
bundler (>= 1.3.0, < 2.0)
railties (= 4.0.5)
sprockets-rails (~> 2.0.0)
railties (4.0.5)
actionpack (= 4.0.5)
activesupport (= 4.0.5)
rake (>= 0.8.7)
thor (>= 0.18.1, < 2.0)
rake (10.3.2)
ransack (1.1.0)
actionpack (>= 3.0)
activerecord (>= 3.0)
polyamorous (~> 0.6.0)
ref (1.0.5)
rspec-collection_matchers (1.0.0)
rspec-expectations (>= 2.99.0.beta1)
rspec-core (2.99.2)
rspec-expectations (2.99.2)
diff-lcs (>= 1.1.3, < 2.0)
rspec-mocks (2.99.2)
rspec-rails (2.99.0)
actionpack (>= 3.0)
activemodel (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
rspec-collection_matchers
rspec-core (~> 2.99.0)
rspec-expectations (~> 2.99.0)
rspec-mocks (~> 2.99.0)
rubyzip (1.1.6)
safe_yaml (1.0.4)
sass (3.4.6)
sass-rails (4.0.1)
railties (>= 4.0.0, < 5.0)
sass (>= 3.1.10)
sprockets-rails (~> 2.0.0)
selenium-webdriver (2.43.0)
childprocess (~> 0.5)
multi_json (~> 1.0)
rubyzip (~> 1.0)
websocket (~> 1.0)
simplecov (0.9.1)
docile (~> 1.1.0)
multi_json (~> 1.0)
simplecov-html (~> 0.8.0)
simplecov-html (0.8.0)
sisow (1.5)
crack
hashie
httpi
spree_api (2.2.2)
rabl (= 0.9.3)
spree_core (= 2.2.2)
versioncake (~> 1.2.0)
spree_core (2.2.2)
activemerchant (~> 1.42.3)
acts_as_list (= 0.3.0)
awesome_nested_set (~> 3.0.0.rc.3)
aws-sdk (= 1.27.0)
cancan (~> 1.6.10)
deface (~> 1.0.0)
ffaker (~> 1.16)
font-awesome-rails (~> 4.0)
friendly_id (= 5.0.3)
highline (~> 1.6.18)
httparty (~> 0.11)
json (~> 1.7)
kaminari (~> 0.15.0)
monetize
paperclip (~> 3.4.1)
paranoia (~> 2.0)
rails (~> 4.0.5)
ransack (~> 1.1.0)
state_machine (= 1.2.0)
stringex (~> 1.5.1)
truncate_html (= 0.9.2)
spree_frontend (2.2.2)
canonical-rails (~> 0.0.4)
jquery-rails (~> 3.1.0)
spree_api (= 2.2.2)
spree_core (= 2.2.2)
stringex (~> 1.5.1)
sprockets (2.12.2)
hike (~> 1.2)
multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sprockets-rails (2.0.1)
actionpack (>= 3.0)
activesupport (>= 3.0)
sprockets (~> 2.8)
sqlite3 (1.3.9)
state_machine (1.2.0)
stringex (1.5.1)
therubyracer (0.12.1)
libv8 (~> 3.16.14.0)
ref
thor (0.19.1)
thread_safe (0.3.4)
tilt (1.4.1)
treetop (1.4.15)
polyglot
polyglot (>= 0.3.1)
truncate_html (0.9.2)
tzinfo (0.3.42)
uuidtools (2.1.5)
versioncake (1.2.0)
actionpack (>= 3.2)
activesupport (>= 3.2)
railties (>= 3.2)
tzinfo
warden (1.2.3)
rack (>= 1.0)
webmock (1.20.0)
addressable (>= 2.3.6)
crack (>= 0.3.2)
websocket (1.2.1)
xpath (2.0.0)
nokogiri (~> 1.3)

PLATFORMS
ruby

DEPENDENCIES
capybara (~> 2.1)
coffee-rails
database_cleaner
factory_girl (~> 4.2)
ffaker
rspec-rails (~> 2.13)
sass-rails
selenium-webdriver
simplecov
spree_auth_devise!
spree_billing_sisow!
sqlite3
therubyracer
webmock

Loading…
Cancel
Save